import re
regex = re.compile(r"^(?:\d{7}[\da-zA-Z]\d{0,2}|\d{1,7})$", flags=re.MULTILINE)
test_str = ("1\n"
"123\n"
"1234567890\n"
"1234567a\n\n"
"1a\n"
"123456789a\n"
"12345678901")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")