import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{7}[\\da-zA-Z]\\d{0,2}|\\d{1,7})$";
final String string = "1\n"
+ "123\n"
+ "1234567890\n"
+ "1234567a\n\n"
+ "1a\n"
+ "123456789a\n"
+ "12345678901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}