# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:owner-name|owner|name)\b/\"$0\"/gm;t' <<< "SELECT abc.name,abc.owner-name FROM XXX"