package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:owner-name|owner|name)\b`)
var str = `SELECT abc.name,abc.owner-name FROM XXX`
var substitution = "\"$0\""
fmt.Println(re.ReplaceAllString(str, substitution))
}