use strict;
my $str = 'SELECT abc.name,abc.owner-name FROM XXX';
my $regex = qr/\b(?:owner-name|owner|name)\b/mp;
my $subst = '\\"$0\\"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";