$re = '/\b(?:owner-name|owner|name)\b/m';
$str = 'SELECT abc.name,abc.owner-name FROM XXX';
$subst = "\"$0\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;