using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:owner-name|owner|name)\b";
string substitution = @"\""$0\""";
string input = @"SELECT abc.name,abc.owner-name FROM XXX";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}