re = /\b(?:owner-name|owner|name)\b/m
str = 'SELECT abc.name,abc.owner-name FROM XXX'
subst = '\\"$0\\"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result