#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)OUTRAS INFORMA..ES.*(?:\r\n?|\n)(?:[^\n\r]+(?:\r\n?|\n)){3}(\d{1,3}(?:\.\d{3})*,\d{2})"
Local $sString = "9135,456,07 " & @CRLF & _
"8.571.962,06 " & @CRLF & _
"OUTRAS INFORMAÇÕES " & @CRLF & _
"Rendimentos isentos e não tributáveis " & @CRLF & _
"0.00 " & @CRLF & _
"254.878,00 " & @CRLF & _
"0,00 " & @CRLF & _
"Rendimentos sujeitos a tributação exclusiva/definitiva " & @CRLF & _
"Rendimentos tributáveis - imposto con exigibilidade suspensa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")