// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)OUTRAS INFORMA..ES.*(?:\r\n?|\n)(?:[^\n\r]+(?:\r\n?|\n)){3}(\d{1,3}(?:\.\d{3})*,\d{2})").unwrap();
let string = "9135,456,07
8.571.962,06
OUTRAS INFORMAÇÕES
Rendimentos isentos e não tributáveis
0.00
254.878,00
0,00
Rendimentos sujeitos a tributação exclusiva/definitiva
Rendimentos tributáveis - imposto con exigibilidade suspensa";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}