$re = '/OUTRAS INFORMA..ES.*(?:\r\n?|\n)(?:[^\n\r]+(?:\r\n?|\n)){3}(\d{1,3}(?:\.\d{3})*,\d{2})/m';
$str = '9135,456,07
8.571.962,06
OUTRAS INFORMAÇÕES
Rendimentos isentos e não tributáveis
0.00
254.878,00
0,00
Rendimentos sujeitos a tributação exclusiva/definitiva
Rendimentos tributáveis - imposto con exigibilidade suspensa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);