const regex = /OUTRAS INFORMA..ES.*(?:\r\n?|\n)(?:[^\n\r]+(?:\r\n?|\n)){3}(\d{1,3}(?:\.\d{3})*,\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('OUTRAS INFORMA..ES.*(?:\\r\\n?|\\n)(?:[^\\n\\r]+(?:\\r\\n?|\\n)){3}(\\d{1,3}(?:\\.\\d{3})*,\\d{2})', 'gm')
const str = `9135,456,07
8.571.962,06
OUTRAS INFORMAÇÕES
Rendimentos isentos e não tributáveis
0.00
254.878,00
0,00
Rendimentos sujeitos a tributação exclusiva/definitiva
Rendimentos tributáveis - imposto con exigibilidade suspensa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}