import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "OUTRAS INFORMA..ES.*(?:\\r\\n?|\\n)(?:[^\\n\\r]+(?:\\r\\n?|\\n)){3}(\\d{1,3}(?:\\.\\d{3})*,\\d{2})";
final String string = "9135,456,07 \n"
+ "8.571.962,06 \n"
+ "OUTRAS INFORMAÇÕES \n"
+ "Rendimentos isentos e não tributáveis \n"
+ "0.00 \n"
+ "254.878,00 \n"
+ "0,00 \n"
+ "Rendimentos sujeitos a tributação exclusiva/definitiva \n"
+ "Rendimentos tributáveis - imposto con exigibilidade suspensa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}