import re
regex = re.compile(r"OUTRAS INFORMA..ES.*(?:\r\n?|\n)(?:[^\n\r]+(?:\r\n?|\n)){3}(\d{1,3}(?:\.\d{3})*,\d{2})", flags=re.MULTILINE)
test_str = ("9135,456,07 \n"
"8.571.962,06 \n"
"OUTRAS INFORMAÇÕES \n"
"Rendimentos isentos e não tributáveis \n"
"0.00 \n"
"254.878,00 \n"
"0,00 \n"
"Rendimentos sujeitos a tributação exclusiva/definitiva \n"
"Rendimentos tributáveis - imposto con exigibilidade suspensa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")