package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)OUTRAS INFORMA..ES.*(?:\r\n?|\n)(?:[^\n\r]+(?:\r\n?|\n)){3}(\d{1,3}(?:\.\d{3})*,\d{2})`)
var str = `9135,456,07
8.571.962,06
OUTRAS INFORMAÇÕES
Rendimentos isentos e não tributáveis
0.00
254.878,00
0,00
Rendimentos sujeitos a tributação exclusiva/definitiva
Rendimentos tributáveis - imposto con exigibilidade suspensa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}