#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)POLYGON\((.*)\)"
Local $sString = " ID geometry" & @CRLF & _
"0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))" & @CRLF & _
"1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")