package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)POLYGON\((.*)\)`)
var str = ` ID geometry
0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))
1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}