import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "POLYGON\\((.*)\\)";
final String string = " ID geometry\n"
+ "0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))\n"
+ "1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}