# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"POLYGON\((.*)\)"
test_str = (" ID geometry\n"
"0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))\n"
"1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.