using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"POLYGON\((.*)\)";
string input = @" ID geometry
0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))
1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}