use strict;
my $str = ' ID geometry
0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))
1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))';
my $regex = qr/POLYGON\((.*)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}