// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)POLYGON\((.*)\)").unwrap();
let string = " ID geometry
0 1 POLYGON((2.9544435 6.3245124, 2.4098938 6.42657389...))
1 2 POLYGON((3.4324624 6.8735201, 2.4590825 6.23098357...))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}