# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(?:[^<>]*?\salt="([^"]*)")?[^<>]*>/$1/gm;t' <<< "<p>test emoji <span title=\"Smile\" class=\"animated-emoticon-20-smile\"><img title=\"Smile\" alt=\"🙂\"></span> and more <span title=\"Emo\" class=\"animated-emoticon-20-emo\"><img title=\"Emo\" alt=\"😑\" target=\"_blank\"></span><span title=\"Star eyes\" class=\"animated-emoticon-20-stareyes\"><img title=\"Star eyes\" alt=\"🤩\"></span></p>"