using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:[^<>]*?\salt=""([^""]*)"")?[^<>]*>";
string substitution = @"$1";
string input = @"<p>test emoji <span title=""Smile"" class=""animated-emoticon-20-smile""><img title=""Smile"" alt=""🙂""></span> and more <span title=""Emo"" class=""animated-emoticon-20-emo""><img title=""Emo"" alt=""😑"" target=""_blank""></span><span title=""Star eyes"" class=""animated-emoticon-20-stareyes""><img title=""Star eyes"" alt=""🤩""></span></p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}