import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:[^<>]*?\\salt=\"([^\"]*)\")?[^<>]*>";
final String string = "<p>test emoji <span title=\"Smile\" class=\"animated-emoticon-20-smile\"><img title=\"Smile\" alt=\"🙂\"></span> and more <span title=\"Emo\" class=\"animated-emoticon-20-emo\"><img title=\"Emo\" alt=\"😑\" target=\"_blank\"></span><span title=\"Star eyes\" class=\"animated-emoticon-20-stareyes\"><img title=\"Star eyes\" alt=\"🤩\"></span></p>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}