// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<(?:[^<>]*?\salt="([^"]*)")?[^<>]*>"#).unwrap();
let string = "<p>test emoji <span title=\"Smile\" class=\"animated-emoticon-20-smile\"><img title=\"Smile\" alt=\"🙂\"></span> and more <span title=\"Emo\" class=\"animated-emoticon-20-emo\"><img title=\"Emo\" alt=\"😑\" target=\"_blank\"></span><span title=\"Star eyes\" class=\"animated-emoticon-20-stareyes\"><img title=\"Star eyes\" alt=\"🤩\"></span></p>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}