use strict;
my $str = '<p>test emoji <span title="Smile" class="animated-emoticon-20-smile"><img title="Smile" alt="🙂"></span> and more <span title="Emo" class="animated-emoticon-20-emo"><img title="Emo" alt="😑" target="_blank"></span><span title="Star eyes" class="animated-emoticon-20-stareyes"><img title="Star eyes" alt="🤩"></span></p>';
my $regex = qr/<(?:[^<>]*?\salt="([^"]*)")?[^<>]*>/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";