const regex = /<(?:[^<>]*?\salt="([^"]*)")?[^<>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:[^<>]*?\\salt="([^"]*)")?[^<>]*>', 'gm')
const str = `<p>test emoji <span title="Smile" class="animated-emoticon-20-smile"><img title="Smile" alt="🙂"></span> and more <span title="Emo" class="animated-emoticon-20-emo"><img title="Emo" alt="😑" target="_blank"></span><span title="Star eyes" class="animated-emoticon-20-stareyes"><img title="Star eyes" alt="🤩"></span></p>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);