#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*?={([^{}]*)}.*"
Local $sString = "={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\n " & @CRLF & _
"author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\n " & @CRLF & _
"journal={Journal of the ACM (JACM)},\n " & @CRLF & _
"volume={38},\n " & @CRLF & _
"number={3},\n " & @CRLF & _
"pages={690--728},\n " & @CRLF & _
"year={1991},\n " & @CRLF & _
"publisher={ACM New York, NY, USA}\n}"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)