# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*?={([^{}]*)}.*"
test_str = ("={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\\n \n"
"author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\\n \n"
"journal={Journal of the ACM (JACM)},\\n \n"
"volume={38},\\n \n"
"number={3},\\n \n"
"pages={690--728},\\n \n"
"year={1991},\\n \n"
"publisher={ACM New York, NY, USA}\\n}")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.