const regex = /.*?={([^{}]*)}.*/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?={([^{}]*)}.*', 'gs')
const str = `={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\\n
author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\\n
journal={Journal of the ACM (JACM)},\\n
volume={38},\\n
number={3},\\n
pages={690--728},\\n
year={1991},\\n
publisher={ACM New York, NY, USA}\\n}`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);