// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s).*?={([^{}]*)}.*").unwrap();
let string = "={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\\n
author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\\n
journal={Journal of the ACM (JACM)},\\n
volume={38},\\n
number={3},\\n
pages={690--728},\\n
year={1991},\\n
publisher={ACM New York, NY, USA}\\n}";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}