import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?=\\{([^\\{\\}]*)\\}.*";
final String string = "={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\\n \n"
+ "author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\\n \n"
+ "journal={Journal of the ACM (JACM)},\\n \n"
+ "volume={38},\\n \n"
+ "number={3},\\n \n"
+ "pages={690--728},\\n \n"
+ "year={1991},\\n \n"
+ "publisher={ACM New York, NY, USA}\\n}";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}