using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?={([^{}]*)}.*";
string substitution = @"\1";
string input = @"={Proofs that yield nothing but their validity or all languages in NP have zero-knowledge proof systems},\n
author={Goldreich, Oded and Micali, Silvio and Wigderson, Avi},\n
journal={Journal of the ACM (JACM)},\n
volume={38},\n
number={3},\n
pages={690--728},\n
year={1991},\n
publisher={ACM New York, NY, USA}\n}";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}