#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:BE)?\s*?[0-1]?((\d[. ]*){9})$"
Local $sString = "BE 0123.321.123" & @CRLF & _
"BE0123.321.123" & @CRLF & _
"BE0123 321 123" & @CRLF & _
"1123.321.123" & @CRLF & _
"123.321.123" & @CRLF & _
"123321123" & @CRLF & _
"BE1233221221" & @CRLF & _
"BE123322122" & @CRLF & _
"BE 0123..... 321 122" & @CRLF & _
"BE 01 23 32 11 23" & @CRLF & _
"aae233432233 23343"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")