const regex = /^(?:BE)?\s*?[0-1]?((\d[. ]*){9})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:BE)?\\s*?[0-1]?((\\d[. ]*){9})$', 'gm')
const str = `BE 0123.321.123
BE0123.321.123
BE0123 321 123
1123.321.123
123.321.123
123321123
BE1233221221
BE123322122
BE 0123..... 321 122
BE 01 23 32 11 23
aae233432233 23343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}