// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:BE)?\s*?[0-1]?((\d[. ]*){9})$").unwrap();
let string = "BE 0123.321.123
BE0123.321.123
BE0123 321 123
1123.321.123
123.321.123
123321123
BE1233221221
BE123322122
BE 0123..... 321 122
BE 01 23 32 11 23
aae233432233 23343";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}