import Foundation
let pattern = #"^(?:BE)?\s*?[0-1]?((\d[. ]*){9})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
BE 0123.321.123
BE0123.321.123
BE0123 321 123
1123.321.123
123.321.123
123321123
BE1233221221
BE123322122
BE 0123..... 321 122
BE 01 23 32 11 23
aae233432233 23343
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)