re = /^(?:BE)?\s*?[0-1]?((\d[. ]*){9})$/m
str = 'BE 0123.321.123
BE0123.321.123
BE0123 321 123
1123.321.123
123.321.123
123321123
BE1233221221
BE123322122
BE 0123..... 321 122
BE 01 23 32 11 23
aae233432233 23343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end