import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:BE)?\\s*?[0-1]?((\\d[. ]*){9})$";
final String string = "BE 0123.321.123\n"
+ "BE0123.321.123\n"
+ "BE0123 321 123\n"
+ "1123.321.123\n"
+ "123.321.123\n"
+ "123321123\n"
+ "BE1233221221\n"
+ "BE123322122\n"
+ "BE 0123..... 321 122\n"
+ "BE 01 23 32 11 23\n"
+ "aae233432233 23343";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}