using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
(^\s*""(?:match|begin|end)""\s*:\s*)
("")
(?:
(?=\2)
|
(?:
(?<esc>(?:\\\\(?:\\\\|[nsrbwSNRW""\$\^\*\)\(\[\]\{\}]?)))
|
(?<ctrl>[\(\)\[\]\{\}]+|[^""\(\)\[\]\{\}\\]+)
|
(?<def>[^""\\])
)+
)
(\2)";
string input = @"{
""repository"": {
""meta"": {
""patterns"": [
{
""begin"": ""\\$\\(\\("",
""end"": ""\\)\\)"",
// ""name"": ""meta.arithmetic-expansion.zsh"",
""name"": ""storage.type.zsh"",
},
{
""begin"": ""\\$\\("",
""end"": ""\\)"",
// ""name"": ""meta.command-substitution.zsh"",
""name"": ""storage.type.zsh"",
},
{
""begin"": ""\\$\\{"",
""end"": ""\\}"",
// ""name"": ""meta.parameter-expansion.zsh"",
""name"": ""storage.type.zsh"",
}
]
}
}
}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}