import Foundation
let pattern = #"""
(?x)
(^\s*"(?:match|begin|end)"\s*:\s*)
(")
(?:
(?=\2)
|
(?:
(?<esc>(?:\\\\(?:\\\\|[nsrbwSNRW"\$\^\*\)\(\[\]\{\}]?)))
|
(?<ctrl>[\(\)\[\]\{\}]+|[^"\(\)\[\]\{\}\\]+)
|
(?<def>[^"\\])
)+
)
(\2)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
"repository": {
"meta": {
"patterns": [
{
"begin": "\\$\\(\\(",
"end": "\\)\\)",
// "name": "meta.arithmetic-expansion.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\$\\(",
"end": "\\)",
// "name": "meta.command-substitution.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\$\\{",
"end": "\\}",
// "name": "meta.parameter-expansion.zsh",
"name": "storage.type.zsh",
}
]
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)