use strict;
my $str = '{
"repository": {
"meta": {
"patterns": [
{
"begin": "\\\\$\\\\(\\\\(",
"end": "\\\\)\\\\)",
// "name": "meta.arithmetic-expansion.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\\\$\\\\(",
"end": "\\\\)",
// "name": "meta.command-substitution.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\\\$\\\\{",
"end": "\\\\}",
// "name": "meta.parameter-expansion.zsh",
"name": "storage.type.zsh",
}
]
}
}
}
';
my $regex = qr/(?x)
(^\s*"(?:match|begin|end)"\s*:\s*)
(")
(?:
(?=\2)
|
(?:
(?<esc>(?:\\\\(?:\\\\|[nsrbwSNRW"\$\^\*\)\(\[\]\{\}]?)))
|
(?<ctrl>[\(\)\[\]\{\}]+|[^"\(\)\[\]\{\}\\]+)
|
(?<def>[^"\\])
)+
)
(\2)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}