// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?x)
(^\s*"(?:match|begin|end)"\s*:\s*)
(")
(?:
(?=\2)
|
(?:
(?<esc>(?:\\\\(?:\\\\|[nsrbwSNRW"\$\^\*\)\(\[\]\{\}]?)))
|
(?<ctrl>[\(\)\[\]\{\}]+|[^"\(\)\[\]\{\}\\]+)
|
(?<def>[^"\\])
)+
)
(\2)"#).unwrap();
let string = "{
\"repository\": {
\"meta\": {
\"patterns\": [
{
\"begin\": \"\\\\$\\\\(\\\\(\",
\"end\": \"\\\\)\\\\)\",
// \"name\": \"meta.arithmetic-expansion.zsh\",
\"name\": \"storage.type.zsh\",
},
{
\"begin\": \"\\\\$\\\\(\",
\"end\": \"\\\\)\",
// \"name\": \"meta.command-substitution.zsh\",
\"name\": \"storage.type.zsh\",
},
{
\"begin\": \"\\\\$\\\\{\",
\"end\": \"\\\\}\",
// \"name\": \"meta.parameter-expansion.zsh\",
\"name\": \"storage.type.zsh\",
}
]
}
}
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}