re = /(?x)
(^\s*"(?:match|begin|end)"\s*:\s*)
(")
(?:
(?=\2)
|
(?:
(?<esc>(?:\\\\(?:\\\\|[nsrbwSNRW"\$\^\*\)\(\[\]\{\}]?)))
|
(?<ctrl>[\(\)\[\]\{\}]+|[^"\(\)\[\]\{\}\\]+)
|
(?<def>[^"\\])
)+
)
(\2)/m
str = '{
"repository": {
"meta": {
"patterns": [
{
"begin": "\\\\$\\\\(\\\\(",
"end": "\\\\)\\\\)",
// "name": "meta.arithmetic-expansion.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\\\$\\\\(",
"end": "\\\\)",
// "name": "meta.command-substitution.zsh",
"name": "storage.type.zsh",
},
{
"begin": "\\\\$\\\\{",
"end": "\\\\}",
// "name": "meta.parameter-expansion.zsh",
"name": "storage.type.zsh",
}
]
}
}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end