#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*"
Local $sString = "Some text here before at and some more words before another at"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)