$re = '/.*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*/m';
$str = 'Some text here before at and some more words before another at';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;