using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*";
string substitution = @"\1";
string input = @"Some text here before at and some more words before another at";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}