// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*").unwrap();
let string = "Some text here before at and some more words before another at";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}