package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?\ba(?:t|round)\W+(\w+(?:\W+\w+){0,2}).*`)
var str = `Some text here before at and some more words before another at`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}